A função SE no Excel

01 de Abril de 2011

Dando seqüência aos artigos sobre funções do Excel, apresento aqui a função SE, que tem o objetivo de apresentar determinado valor ou equação, de acordo com uma condição estipulada.

Sintaxe: =SE(teste lógico;condição se verdadeiro;condição se falso)


No exemplo abaixo podemos ver uma tabela com as notas obtidas por alguns alunos





A fórmula está bem simples, se a célula C3 for maior que 6, o resultado exibido será aprovado, senão exibirá reprovado.

Na seqüência arrastamos essa célula para baixo copiando em todas as células restantes.




Nota-se que existe um detalhe, pois se a nota for igual a 6, exibirá reprovado, nesse caso mudamos a fórmula para >= .

Podemos ampliar as condições para se chegar a exibições mais detalhadas como no exemplo abaixo




Analisando a fórmula:

=SE(C3>=9;"Conceito A";SE(C3>=7,5;"Conceito B";SE(C3>=6;"Conceito C";SE(C3>=4,5;"Conceito D";"Conceito E"))))


Perceba que a condição vai mudando conforme ele não encontra a condição estipulada.

Arrastamos até o final da planilha e temos os respectivos conceitos.





Uma última dica, o Excel suporta até 7 vezes a repetição do SE, depois disso ele exibe um erro. Para resolver isso, preencha depois da última condição SE, o local onde estará o restante da fórmula, como no exemplo abaixo.

=SE(C3>=9;"Conceito A";SE(C3>=7,5;"Conceito B";SE(C3>=6;"Conceito C";SE(C3>=4,5;"Conceito D";SE(C3>=4;"Conceito E";SE(C3>=3,5;"Conceito F";SE(C3>=3;"Conceito G";SE(C3>=2,5;"Conceito H";E3))))))))

E na célula E3 é digitada a seguinte fórmula:

=SE(C3>=2;"Conceito I";SE(C3>=0;"Conceito J"))



Leia também A função PROCV no Excel

Enviado por: Marcelo   Categoria:  excel planilhas




Alguns direitos reservados para Administrando sempre - www.administrando.net.br

Contato marcelo@administrando.net.br ou acesse o formulário de contato

A reprodução de qualquer conteúdo desse site total ou parcial é permitida somente com a autorização do autor