A função SE no Excel

Dando seqüência aos artigos sobre funções do Excel, apresento aqui a função SE, que tem o objetivo de apresentar determinado valor ou equação, de acordo com uma condição estipulada.

Sintaxe: =SE(teste lógico;condição se verdadeiro;condição se falso)


No exemplo abaixo podemos ver uma tabela com as notas obtidas por alguns alunos





A fórmula está bem simples, se a célula C3 for maior que 6, o resultado exibido será aprovado, senão exibirá reprovado.

Na seqüência arrastamos essa célula para baixo copiando em todas as células restantes.




Nota-se que existe um detalhe, pois se a nota for igual a 6, exibirá reprovado, nesse caso mudamos a fórmula para >= .

Podemos ampliar as condições para se chegar a exibições mais detalhadas como no exemplo abaixo




Analisando a fórmula:

=SE(C3>=9;"Conceito A";SE(C3>=7,5;"Conceito B";SE(C3>=6;"Conceito C";SE(C3>=4,5;"Conceito D";"Conceito E"))))


Perceba que a condição vai mudando conforme ele não encontra a condição estipulada.

Arrastamos até o final da planilha e temos os respectivos conceitos.





Uma última dica, o Excel suporta até 7 vezes a repetição do SE, depois disso ele exibe um erro. Para resolver isso, preencha depois da última condição SE, o local onde estará o restante da fórmula, como no exemplo abaixo.

=SE(C3>=9;"Conceito A";SE(C3>=7,5;"Conceito B";SE(C3>=6;"Conceito C";SE(C3>=4,5;"Conceito D";SE(C3>=4;"Conceito E";SE(C3>=3,5;"Conceito F";SE(C3>=3;"Conceito G";SE(C3>=2,5;"Conceito H";E3))))))))

E na célula E3 é digitada a seguinte fórmula:

=SE(C3>=2;"Conceito I";SE(C3>=0;"Conceito J"))



Leia também A função PROCV no Excel

Enviado por: Marcelo   Categoria:  excel planilhas

3 comentários | comente este artigo | ver comentários



Amigo, não consigo resolver uma questão.
Preciso que o excel me indique o nível de um nutriente no solo quando eu digitar o valor na célula L4.
Se o nutriente estiver abaixo de 20 ele é limitante, se estiver entre 21 e 40 é muito baixo, se estiver entre 41 e 60 está BAIXO. Se estiver entre 61 e 80 MEDIO e se estiver entre 81 e 120 está SUFICIENTE. Acima de 120 está ALTO.

Fiz esta formula, porém, qualquer valor acima de 21 que eu digite na célula L4, o excel retorna o valor MUITO BAIXO

=SE(L4<=20;"Limitante";SE(L4>=21;"Muito Baixo";SE(L4>=41;"Baixo";SE(L4>=61;"Médio";SE(L4>=81;"Suficiente";SE(L4>120;"Alto"))))))

Oque é que está errado na minha fórmula? Preciso muito que ela funcione. Obrigado!

Diogo Luiz - 24/06/2012

http://

Utilize a fórmula como segue.


=SE(L4<=20;"Limitante";SE(L4<=41;"Muito Baixo";SE(L4<=61;"Baixo";SE(L4<=81;"Médio";SE(L4<=121;"Suficiente";"Alto")))))

Abraço, espero ter ajudado.

Marcelo - 25/06/2012

http://

Estou com um problema em uma planilha:

Tenha duas colunas de CNPJ e preciso que, em uma terceira coluna, retorne o valor "Cadastrado" ou "Não cadastrado", conforme os CNPJ's da primeira coluna apareçam na segunda.

Fiz a fórmula:

=SE(B2=D$2:D$2208; "Cadastrado"; "Não cadastrado")

Porém, só recebo o valor "Não cadastrado", mesmo sabendo que a maioria dos CNPJ's da primeira coluna estão cadastrados na segunda. Preciso desse resultado para que, caso sejam inseridos outros números na primeira coluna, seja informado se estão cadastrados ou não no banco de dados.

Obrigado!

Hugo - 16/12/2013

http://


Deixe seu comentário

Nome

Email (Obrigatório, mas não será divulgado)

Site ou blog (Opcional)

Anti-spam - digite a posição 4 dos números abaixo (esquerda para a direita)

3577 

Comentário

Cotações
Tradução

Alguns direitos reservados para Administrando sempre - www.administrando.net.br

Contato marcelo@administrando.net.br ou acesse o formulário de contato

A reprodução de qualquer conteúdo desse site total ou parcial é permitida somente com a autorização do autor